Get updates
Status
Activity
Activity
Bird fleet outage
Started
Wed, Jun 10
Lasted 18min
MAJOR
affected
Fleets
RESOLVED
lasted 18min
The incident has been resolved
19:12
INVESTIGATING
18min earlier
Bird fleet count is low
18:53